Electrical fault - won't start - relay info please?


  1. Welcome to Audi R8 Forum : Audi R8 forums – General discussion forum for Audi R8

    Welcome to Audi R8 Forum : Audi R8 forums - a website dedicated to all things Audi R8.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Audi R8 Forum : Audi R8 forums today!
     
Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Electrical fault - won't start - relay info please?

  1. #1
    Senior Member
    Join Date
    Sep 2018
    Posts
    164

    Electrical fault - won't start - relay info please?

    A few times the car has said ESP Fault & Brakes when starting, but started anyway, Now it won't start at all and I get those 2 messages. It is a manual V8 BTW

    I have 12.16V on the battery according to my multimeter which should turn it over - the car hasn't been used for a week or so but that's usually OK. Got a good run 6 days ago - 2x 40 minute motorway / highway runs - I don't think it is the battery

    I saw on here someone suffered this & it was the 'main supply relay' that needed replacing - I am assuming that is on the main relay board in the assenger footwell

    Can anyone tell me which relay it is & what type I need to swap it for - as something to try before getting it trailered away

    I am hoping it isn't a bad ECU...

  2. Remove Advertisements
    Audi R8 Forum
    Advertisements
     

  3. #2
    Member
    Join Date
    Jul 2017
    Location
    Vancouver, Canada
    Posts
    69

    Re: Electrical fault - won't start - relay info please?

    I have not had this one yet, knock on wood
    but here are the wiring diagrams that might help
    https://www.dropbox.com/s/ziuzzvb93u...ation.pdf?dl=0
    https://www.dropbox.com/s/5h0j6p0vxn...tions.pdf?dl=0
    White 2010 R8 V10, R-Tronic, Michelin Pilot Sport 4S, Stasis exhaust

  4. #3
    Senior Member
    Join Date
    Sep 2018
    Posts
    164

    Re: Electrical fault - won't start - relay info please?

    Electrical fault - won't start - relay info please?-img_3639.jpg

    The recovery guy got this off diagnostics
    He advised swapping main relay & going from there but he didn't have the correct type of relay on his van to test so I can try tomorrow morning
    I hope this rules out the actual ECU being faulty as that is expensive

  5. Remove Advertisements
    Audi R8 Forum
    Advertisements
     

  6. #4
    Senior Member
    Join Date
    Sep 2018
    Posts
    164

    Re: Electrical fault - won't start - relay info please?




    The recovery guy got this off diagnostics
    He advised swapping main relay & going from there but he didn't have the correct type of relay on his van to test so I can try tomorrow morning
    I hope this rules out the actual ECU being faulty as that is expensive

  7. #5
    Senior Member
    Join Date
    Sep 2018
    Posts
    164

    Re: Electrical fault - won't start - relay info please?




    The recovery guy got this off diagnostics
    He advised swapping main relay & going from there but he didn't have the correct type of relay on his van to test so I can try tomorrow morning
    I hope this rules out the actual ECU being faulty as that is expensive

  8. #6
    Senior Member Tweaky's Avatar
    Join Date
    Sep 2013
    Location
    Hampshire UK
    Posts
    390

    Re: Electrical fault - won't start - relay info please?

    I recently had a similar situation with symptoms and diagnostic readings like these, which turned out to be an earth bonding wire where the nut had vibrated loose causing arcing. This plastic unit holds relays and is located behind the rear shelf panel.

    Electrical fault - won't start - relay info please?-1bd40323-a00e-43c6-b876-b3f382b740b1.jpg

    The replacement relay cradle was £20 plus an hours labour to fit.
    Last edited by Tweaky; 05-19-2019 at 02:58 PM.
    R8 V10 6MT shortens straights and straightens curves.

    Neidfaktor complete stitched leather interior.
    Audi OEM carbon parts:
    'exklusiv' rear diffuser|carbon front lip|carbon engine bay|
    Aftermarket carbon parts:
    Interior engine bay lid|illuminated outer sills|inner sills|door trims|trunk surround
    Other parts:
    stitched alcantara trunk|stitched steering wheel|embroidered logo alcantara mats|
    MMI 3G|phone cradle with SDS high|1Tb hard drive|Kufatec TV|interior light and switch upgrade.

  9. #7
    Senior Member DaveL's Avatar
    Join Date
    Mar 2015
    Location
    Fortaleza, Ceará, Brasil.
    Posts
    1,898

    Re: Electrical fault - won't start - relay info please?

    Quote Originally Posted by Tweaky View Post
    I recently had a similar situation with symptoms and diagnostic readings like these, which turned out to be an earth bonding wire where the nut had vibrated loose causing arcing. This plastic unit holds relays and is located behind the rear shelf panel.

    Click image for larger version. 

Name:	1BD40323-A00E-43C6-B876-B3F382B740B1.jpg 
Views:	14 
Size:	290.1 KB 
ID:	235390

    The replacement relay cradle was £20 plus an hours labour to fit.
    An interesting observation for potential future problems,
    Black/Gold 09 V8 Coupe R-Tronic. Black/Gold 05 Race prep'd Yamaha R1.

  10. #8
    Senior Member
    Join Date
    Sep 2018
    Posts
    164

    Re: Electrical fault - won't start - relay info please?

    It was all OK this morning after refitting the old relay. I bought a new relay anyway and replaced it due to low price & ease.
    Car is in the shop now for a new front lid
    When I get it back I'll get the rear bench off and check out that earthing point looks like an easy fix if that's it

  11. #9
    Senior Member
    Join Date
    Sep 2018
    Posts
    164

    Re: Electrical fault - won't start - relay info please?

    So this problem again... I think I have identified it as I can now replicate the fault at will but it is a weird one

    If I remove the fuel pump relay, the very top of 2 of the pins (close to the relay, not the tips), are a little discoloured & it has a very slight slight electrical burning whiff about it. With this relay removed, the fault (ESP Fault & Brakes, car not starting) occurs every time I turn ignition on.

    But now that I have ferreted about with it, the car is perfectly fine anyway, as though there was a loose connection or something

    I have tried swapping it with the other relay on the same tray & it seems to be working perfectly with both relays.

    So either the relay is on its way out & the discoloration on the pin and slight smell point to this - or there is a fault in the wiring to or around the relay - I've had a really good look and can't see anything though.

    All I can think of is to replace both relays (they are a very common VAG part for about $8 each) and see how it goes from there as I want to avoid spending on hours of diagnostics if possible and I have use of another car.

    Any thoughts appreciated!

  12. #10
    Senior Member
    Join Date
    Sep 2018
    Posts
    164

    Re: Electrical fault - won't start - relay info please?

    Singed relay terminals - this isn't normal is it!?



    Relay board - if I remove the one on the left completely the fault occurs 100% of the time.
    BEEP - ESP fault
    BEEP BEEP BEEP - Brakes

    If I replace the relay the fault completely disappears

    It's the one on the left. Removing the one on the right or swapping them makes no difference



    And every now and again I get the fault with the relay in place

  13. Remove Advertisements
    Audi R8 Forum
    Advertisements
     

Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 8
    Last Post: 10-25-2016, 12:34 PM
  2. ESP Fault. Car Won't start and Engine Light Is On.
    By Tropicana50 in forum Maintenance and Service
    Replies: 1
    Last Post: 04-27-2013, 05:36 AM
  3. Passenger Door Fault? Central Locking Fault? Door Wont Unlock?
    By pullmr8 in forum Maintenance and Service
    Replies: 0
    Last Post: 11-28-2012, 04:00 PM
  4. PLEASE HELP. Navigation Fault code? Please enter PIN?
    By Toankie in forum Maintenance and Service
    Replies: 4
    Last Post: 11-08-2011, 03:14 PM
  5. Wipers - Relay sound
    By satmarshall in forum General Discussion
    Replies: 10
    Last Post: 05-22-2009, 01:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.3.0